icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.uqiwl.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

江西11选5 www.bx84.com-彩票专业彩吧助手| www.09hv.com-开彩吧lkc8kh| www.883362.com-娜彩快开平台在哪| www.971409.com-彩票分析基础答案| www.cp7977.com-江苏快三是骗人的吗| www.354822.com-盐城彩票中心| www.973281.com-彩虹在线听周杰伦| www.ix63.com-2019年彩票休市| www.4du.com-彩宝贝老谢彩票| www.206842.com-下彩彩票app| www.jd05.com-唯彩足球竞彩网| www.2zd.com-高频彩官方网站平台| www.350001.com-福彩任5玩法| www.496010.com-正规篮球博彩| www.616939.com-怎么查体彩站点查询| www.699962.com-彩客网论坛-| www.783109.com-新星彩下载-| www.868456.com-新浪七星彩走势图| www.955524.com-彩票106app-| 126彩票网www.126509.com| www.jn25.com-江苏快三输钱| www.o83.com-买彩票规则介绍| www.64nn.com-买足彩任9技巧| www.1882.bid-下载贵州多彩宝| www.409228.com-vr3分彩计划| www.536876.com-带彩的网名-| www.682037.com-河北省彩票开奖公告| www.767858.com-华夏彩票手机版下载| www.850916.com-大发时时彩稳赚计划| www.915570.com-新亿彩票算私彩吗| www.975282.com-黑马彩票分解| www.cp3878.com-快频彩湖北快三| www.366650.com-南京彩票兑奖中心| www.476805.com-蚂蚁金服彩票| www.561724.com-快彩平台兼职揭秘| www.647768.com-好彩运-| www.796427.com-彩票3d猜谜-| www.876807.com-体彩怎么看中奖| www.980000.com-搜索福彩三地| www.qf5.cc-乐购彩彩票是真的吗| www.369293.com-5分彩是否为骗局| www.474983.com-boss直彩彩票| www.560765.com-我要中彩票网页| www.860559.com-北京5分彩计划| www.924982.com-福彩彩票游戏规则| www.998881.com-洛杉矶快三-| www.ev56.com-彩票外挂手机版下载| www.yr03.com-榆次体彩中心| www.26we.com-快三跨度投注技巧| www.588182.com-米乐彩票-| www.28762.com-天彩翼飞-| www.419117.com-印象彩票官网| www.522661.com-带人玩彩的微信群| www.590753.com-七×4cc天下彩票| www.343199.com-五分彩开奖走势图| www.402837.com-七星彩一位杀号| www.858318.com-彩迷天地图-| www.gy09.com-财神彩票合法吗| www.571359.com-网上正规买彩票软件| www.676597.com-玩彩老头作独家推荐| www.108474.com-彩票倍投靠谱吗| www.192926.com-335彩票app-| www.272527.com-上海快三最新版本| www.63731.cc-竞彩足球投注量| www.036868.com-彩票软件哪个最可靠| www.5815.cc-谁有一分钟快三计划| www.657488.com-福彩3d大底软件| www.820019.com-七乐彩定胆杀码| www.080613.com-新加坡南洋彩资料| www.192837.com-彩票中奖了不给钱| www.302078.com-特区南国七星彩论坛| www.375383.com-彩金宏辉漏洞| www.532857.com-梦图解码七星彩奖吗| 500万彩票www.500cd.com| www.xc11.com-吉林快三出豹子规律| www.qp13.cc-pc彩票到骗局| www.05qc.com-五彩斑斓的黑| 大赢家彩票平台www.763226.com| www.20be.com-买复式彩票怎么玩法| www.522.date-体彩中了怎么兑奖| www.760631.com-广东南粤好彩1预测| www.8052.cm-创意水彩画儿童| www.47416.com-好彩店苹果版下载| www.765134.com-开心网七星彩论坛| www.622226.com-山东体彩网排三论坛| www.781308.com-同志微彩投资骗局| www.870973.com-投彩网c97下载| 必发彩票www.930557.com| www.254552.com-网赌输了买彩票翻身| www.376761.com-七星彩下载哪个软件| www.574033.com-湖南体彩排列三论坛| www.698337.com-彩库宝典资料大全| www.770178.com-彩票被黑了提不了现| www.849079.com-竞彩258官方客服| www.959934.com-百盈时时彩正规吗| www.cp0993.com-快三分析软件| www.t80.net-福彩正版3d藏机图| www.66qb.com-3k彩票首页-| www.796740.com-足球竞彩任9| www.871242.com-乐赢彩票是骗局揭秘| www.41nq.com-足彩310官方网站| www.8282.vip-福利彩票一期销售额| www.78812.com-体彩查询开奖号码| www.391283.com-重庆时时彩一星追号| www.gn43.com-蚂蚁致富团队彩票| www.9697.in-体彩金七宝下载安装| www.71776.cc-3d彩涂第一版| 快彩www.81678b.com| www.810.in-七乐彩专家杀号澳客| www.8557.in-中彩网3d论坛!| www.38504.cc-购彩网7798-| www.7891.cn-云彩排云送彩票来| www.565229.com-49彩票规则-| www.620590.com-竞彩足球必发指数网| www.192881.com-北京pk拾彩票官网| www.276623.com-吉林快3彩票| www.359606.com-瑞彩祥云苹果版网址| www.464364.com-湖北体彩前三直选| www.13551.cc-竞彩足球串关计算表| www.062400.com-天天中奖彩票靠谱不| www.379797.com-益彩家园-| www.cx38.com-金沙博彩-| www.xs63.com-彩票一注全中多少钱| www.21nj.com-gc彩票投资网| www.165320.com-快三手机计划软件| www.297004.com-彩票k线分析| www.418558.com-附近的足球竞彩店| www.563860.com-今目3d彩涂-| www.654001.com-江西快三和值推荐号| www.773226.com-买彩心得与投注技巧| www.876900.com-买体彩大乐透方法| www.961105.com-4ggy香港天下彩| www.av5.com-足彩新浪-| www.h41.net-彩票看一下-| www.639706.com-刘雪龙彩票案| www.17zc.com-七乐彩加长版走势图| www.2180.pw-今日彩票号是什么| www.139282.com-567彩票安卓| www.263967.com-湖北快三带线走势| www.06gt.com-彩铅花瓶-| www.078.la-彩民村新之家| www.4444.pw-福彩3d五福图库| 尊彩www.472717.com| www.706277.com-时时彩原理计算公式| www.780214.com-彩票神器软件下载| www.887031.com-珍爱网男生引导彩票| www.956322.com-下载全部彩票软件| www.995135.com-福彩主任贪了多少亿| www.cc38.com-福彩快开彩有哪些| www.xv09.com-01彩票下官方| www.69qf.com-彩票杀号技巧大乐透| www.1580.org-最贵的彩票收藏| www.418943.com-彩票买5个数的| www.jz52.com-黑龙江大庆福彩快三| www.48lx.com-青岛星彩-| www.d14.in-福彩3d彩票开奖| www.18111.cc-彩客网竞彩完整比分| www.3sf.com-快乐彩票五-| www.49ng.com-五福彩彩票网站| www.558.mobi-彩票预测诈骗| www.3276.cn-lotto彩票-| www.7793.cm-女人梦见买彩票中奖| www.816339.com-河北快三分析大师| www.888383.com-安然七星彩预测号码|